888,626 Users Worldwide | Login

Project Viewers

Project Viewer

Note: Click here for viewers in general

Note: Click here for information about adding Project Viewers

Using a Project Viewer

A Project viewer is comprised of three panes: Project Tree on the left side, Project Overview on the top right, Task Details on the bottom, and Gantt Chart on the right side.

Project Tree

Project Tree can be used to select the part of the project plan that is shown in the Project Overview and the Task Details. Selecting the top most task will show the entire project, while selecting a subproject or a single task will show the details and the status of that subproject/task.

Note: To quickly hide or show the Project Tree, click on the Hide/Show to the right of the Project Tree at the top of the viewer.

Project Overview

Project Overview shows a view of the selected project, subproject or task. This bar is a quick way to get an overview of an entire project, and its' progress.

The top bar shows the timeline, which will auto-scale to best fit the duration. It may show days, weeks, months or years depending on the space available.

  • The Blue triangle represents current time (now).
  • Green parts of the bar represents completed work
  • Yellow parts of the bar represents not-completed work
  • The black rectangles represents Milestones on the project
  • To get more information on the bars and/or milestones, simply right-click on a bar or milestone, and the drop-down box will tell you the name(s) of milestones, and various other information.

On the picture above, you can quickly see that the project is significantly delayed (The green bar does not extend all the way to the blue marker).

Note: To quickly hide or show the Project Overview, click on the Hide/Show at the top left corner of the viewer.

Task Details

Task Details shows the tasks in detail for the selected project, subproject, or task and optionally filtered by the selected resource (see below). You can also sort tasks by clicking on the desired column header.

  • Double-click on a task to edit it.
  • Tasks are color-coded to provide a quick-overview of their status. Select menu Project > Show Legend to see what the colors mean.
  • Right-Click on any task to show the Context Sensitive menu

Inline Editing

To start inline editing, just select to add a new task or double-click on an existing task.

Context Menu

Most of the actions available when viewing a Project file can be accessed from the context menu.

A subset of this functionality can also be found from the Project Menu.

Add new task

Creates a new task, which will be sent to the manager for approval as a suggestion to the project.

See also Suggestions Options

Edit "Task name"

Opens the Task Information window, which allows the user to edit the task information.

Important Note 1: Some tasks are not editable, in which case the OK button will be disabled. The window will still open so you can see the details of the task.

Important Note 2: Some tasks can only have some fields edited (Such as summary tasks). The other fields are disabled on purpose to avoid sending illegal suggestions.

Important Note 3: Please be aware that LiveProject depends on Microsoft Project to accept your changes. If the Project is configured in such a way that your suggestions are illegal, contact your manager. A good test is to perform your suggestions manually in the Microsoft Project directly, and see if the suggestions are acceptable. In case of a conflict, please let us know.

Suggestions

Suggestions are changes to a project made by team members. We call them 'suggestions' because they are not actual changes to a project plan, but rather suggestions that are visible to the team while pending manager approval. The project plan will never be updates without the manager reviewing pending suggestions and accepting them explicitly.

While suggestions are pending, they will be show in the project viewer in one color (See the legend for a color chart). Once they are accepted or rejects by the manager, they will become part of the project plan, but continue to be highlighted for a period of time to indicate they have changed status.

The following menus provide a way for users to 'clear' these suggestions in various ways :

    Cancel pending suggestions for "task name"

       This menu item is only visible if the task has any pending changes. In that case, selecting this menu will cancel them (if the user has the rights to do so).

    Clear all completed suggestions

        Clear the coloring for completed suggestions in the task table.

    Clear completed suggestions for "task name"

        Selecting this will clear the coloring for completed suggestions for this task only.

Note: The length of time a suggestion is highlighted can be changed via the Context Menu Configure Viewer > Suggestions.

Reset Sort

Resets the sorting to no sorting or to the sorting defined by the current active filter.

Open with MS Project

Selecting this menu will attempt to launch the Project file in Microsoft Project ®. If you do not have Microsoft Project ® (or some other Project viewer) installed, this will fail.

  • If you are the Manager of the project, LiveProject will launch the original project file, from the location it was published from. If the file cannot be found, you will be asked to re-map it to a local file.
  • If you are not a manager, LiveProject will prompt you for the file to open (Assuming you don't have access to the original project at the exact same location as your manager).

Project Details & Settings

Opens the Project Details & Settings window with more information and settings for this Project.

Save current columns as default

Allows the current columns (and the order) to be saved as the default columns for project viewing.

Show Legend

Open a window with the Legend of the project color codes and Gantt Chart information.

You can also customize the colors. Read more at Customize LiveProject Colors.

Auto-Filter

Allows you to filter based on the contents of chosen column. When active the column and the auto-filter drop-down box turn blue. To deactivate an auto-filter, select All from the auto-filter drop-down.

To turn on/off Auto-filtering, just click on the  tool strip item.

See also:

You are viewing the online version of the LiveProject help files. Click here for KaDonk's main pages.